WeTek Community Forum

Cannot login to Netflix 5.3.1anymore after using a VPN

303_trancer303_trancer Posts: 3WeTek Community Member

After using the Core with Libreelec for some time I decided to install WEos 3.0.2 and installed Netflix 5.3.1 according to the instructions. It worked for 3 days. I have a 40 Mbs adsl line and a fre one month Ultra HD Netflix account but I have a 1080p TV. So I thought I would get flawless streaming in 1080p. But that was not the case. I thought maybe my provider was not giving me the full bandwidth so I tried a VPN. But when I started the Netflix app it gave me an error message (I can't remember exactly what) but it was due to the VPN usage. So I stopped the VPN and tried Netflix again. Now it came with the error that my userid or password was wrong. But when I used my tablet to login to Netflix with the same credentials there was no problem. But I changed my password and tried it again. Could still not login on the Core but again on the tablet no problem. Tried so much things like stopping the NF app and cleaning cache etc and trying again. NOK. Removing app and reinstalling the exact same way as before but if doesnt't matter what I try, I can't get that 5.3.1 NF app working again. Even reinstalling Weos 3.0.2 and installing NF 5.3.1 the same way as before, it does not let me login!?!
Can someone explain me what happened? To me it looks like NF has blacklisted my Core's MAC address but the NF helpdesk says NF does not have the possiblity to block users. They told me I had to contact Wetek for a working NF app. They could not tell me however why the same app that worked for 3 days did not work anymore AFTER using a VPN...
I contacted Wetek and after doing everything they suggested ( a clean install of weos 3.0.2 and installing the NF 5.3.1 version) it was still the same. I could not loging to NF. So the told me to contact NF...

I don't know what to do anymore. Any suggestion?

Best Regards


  • TapalqueTapalque Posts: 31WeTek Community Member
    Try NetflixTV apk instead, solved the same problem on my Wetek Core
  • 303_trancer303_trancer Posts: 3WeTek Community Member
    @Tapalque thanks for the info. Do you have a version for me off the apk?
  • TapalqueTapalque Posts: 31WeTek Community Member
    Netflix Android TV v4.16.4
  • AnimaAnima Posts: 1,988WeTek Support Team
    indeed, If you are having problems with log in, give Version 4.16.4 build 200217 a go.

  • raven001raven001 Posts: 4WeTek Community Member
    if your account is not working just go to moddroid. com and download moded version of netflix and watch any thing free of cost without any subcription
Sign In or Register to comment.
© Copyright 2014 - Creative Dreams | Powered by Vanilla
All times are UTC