WeTek Community Forum

[ROM] [Hub] [Marshmallow] Android TV v2.4.1

1568101113

Comments

  • punditpundit Posts: 4WeTek Community Member
    Got it. Kept using the wrong one - play2- sorted out now, I think
  • bruno60bruno60 Posts: 14WeTek Community Member
    @cyberjacob
    To disable CEC go to settings/preferences and you should find HDMI CEC
  • jaybron81jaybron81 Posts: 1WeTek Community Member
    So how long should the initial start-up after installing take? I'm on like 20 minutes.
  • wrxtasywrxtasy Posts: 1,221WeTek Community Member
    Did you do a "Factory Reset" in the Android Recovery screen after flashing the Android TV v2.3 ROM ?
  • verguldebarmanverguldebarman Posts: 5WeTek Community Member
    edited September 2017
    He guys,
    Trying to install this ROM, and also receive error in recovery:

    E: footer is wrong
    E: signature verification failed

    I'm installing from WEOS3.1.

    Checks I already did:
    - Factory reset (of course....)
    - ZIPs are not "incepted".... did a normal download.
    - Retrying download also didn't work
    - Zip for AndroidTV v2.2 and WEOS v3.1 has same issue......
    - used another USB drive, same issue....

    :neutral:

    Do I need another recovery than stock or should this work?

    Any thought/help????
  • EagleEyeXEagleEyeX Posts: 84WeTek Community Member
    i found a technical bug. i have a Logitech k400 plus keyboard. it slows/freeze Android on this device. i had the same problem years ago on a rk3188 SoC... unplug the usb and then restart and the system works like a charm.
  • cecet23cecet23 Posts: 11WeTek Community Member
    Hi,
    thank you for this rom. Finally the hub have a sense.
    I have a problem with one Italian app. Infinity tv, I'm able to sign in but I'm not able to play a movie. I only have a black screen.
    Someone can help me?
  • lorifelorife Posts: 20WeTek Community Member
    Hello,

    I would like to be able to do 3 things:

    1) Connect to my VPN:
    2) remotely turn on the Hub
    3) remotely control the HUB from a computer

    point 1 is easy, regarding 2 and 3 is there only teamviewer or you have better ideas?
    thank you!
  • johnlrose1979johnlrose1979 Posts: 10WeTek Community Member
    edited September 2017
    I just got my hub I downloaded the zip file placed it on my 128 GB micro SD card went into the recovery and it doesn't seem to see my SD card is there something I'm doing wrong?Could it be a problem with the card? just wondering what I'm doing thats not getting me there.
  • johnlrose1979johnlrose1979 Posts: 10WeTek Community Member
    Never mind it was the card had a old 8 gb fat32 and it worked fine
  • duepointeduepointe Posts: 35WeTek Community Member
    my youtube leanback app updated to the latest one.
    playing some youtube video freezes but audio keeps on going..
    i tried to uninstall the update and now youtube is fine.
    anyone encountering this with the new youtube app? thanks.
  • johnlrose1979johnlrose1979 Posts: 10WeTek Community Member
    duepointe said:

    my youtube leanback app updated to the latest one.
    playing some youtube video freezes but audio keeps on going..
    i tried to uninstall the update and now youtube is fine.
    anyone encountering this with the new youtube app? thanks.

    am having this problem, i dont see a leanback youtube app only a leanback launcher, is that the same thing?
  • johnlrose1979johnlrose1979 Posts: 10WeTek Community Member
    edited September 2017
    Am having another odd problem. In the youtube app its self if I go to search for something the select button does not work for each letter it just goes back one screen. It works fine with the remote it came with but with my flirc adapter(select key is mapped to the enter key on a keyboard) it wont work, it works fine in netflix and kodi, not sure what that can be?
  • johnlrose1979johnlrose1979 Posts: 10WeTek Community Member

    duepointe said:

    my youtube leanback app updated to the latest one.
    playing some youtube video freezes but audio keeps on going..
    i tried to uninstall the update and now youtube is fine.
    anyone encountering this with the new youtube app? thanks.

    am having this problem, i dont see a leanback youtube app only a leanback launcher, is that the same thing?
    So I guess the leanback app is just the youtube app?
  • duepointeduepointe Posts: 35WeTek Community Member

    duepointe said:

    my youtube leanback app updated to the latest one.
    playing some youtube video freezes but audio keeps on going..
    i tried to uninstall the update and now youtube is fine.
    anyone encountering this with the new youtube app? thanks.

    am having this problem, i dont see a leanback youtube app only a leanback launcher, is that the same thing?
    So I guess the leanback app is just the youtube app?
    yup the that's the youtube app installed.
    any fix for the youtube freeze issue.
    currently using youtube 2.01.04.
  • johnlrose1979johnlrose1979 Posts: 10WeTek Community Member
    Just realized the select button problem is only on the old version of YouTube app, so I can't downgrade to have stable YouTube since my wife won't be happy no being able to search.
  • bruno60bruno60 Posts: 14WeTek Community Member
    @CyberJacob
    To disable CEC go to settings/preferences/HDMI CEC
  • lorifelorife Posts: 20WeTek Community Member
    @ricardopvz I have a question for you.
    In the event something happens to this forum (i hope not) is there a way to follow you and your updates? thank you!
  • cecet23cecet23 Posts: 11WeTek Community Member
    cecet23 said:

    Hi,
    thank you for this rom. Finally the hub have a sense.
    I have a problem with one Italian app. Infinity tv, I'm able to sign in but I'm not able to play a movie. I only have a black screen.
    Someone can help me?

    Is it possible to debug the application? I don't know maybe with serial cable to the uart?
    Thanks
  • duepointeduepointe Posts: 35WeTek Community Member
    Fyi. Google assistant is working with the rom. using the android tv remote for voice search. https://www.apkmirror.com/apk/google-inc/google-app-for-android-tv-android-tv/google-app-for-android-tv-android-tv-3-0-0-169638836-release/
  • scj643scj643 Posts: 10WeTek Community Member
    Where can one get the source for this so I can build it myself
  • anthonytexanthonytex Posts: 13WeTek Community Member
    hi @ricardopvz i'm using your last rom version with success my primary use is for netflix.
    May i ask if there is a way to disable unwanted daemon (as tvheadend) ? unfortunately Hub has only 1GB of ram, and every MB is precious! I've managed to disable near all android services with telnet but i really don't know how to deal with daemons... The best thing would also be to not start launcher but only netflix directly :) thanks in advance if you can point me through the right direction ;) and thanks for your ROM :)
  • scj643scj643 Posts: 10WeTek Community Member
    What I did to disable tvheadend was telnet in and mv tvheadend then made an empty file named tvheadend
  • scj643scj643 Posts: 10WeTek Community Member
    edited October 2017
    Also at the end of /init.amlogic.rc is how you should be able to disable telnet
  • anthonytexanthonytex Posts: 13WeTek Community Member
    @scj643 good tip;) thanks:) Yes i've thought about init.amlogic.rc but iirc from Android 4(?) The init script must be edit by modify boot Image. I was planning to do It this weekend but that is a clever workaround thanks;)
  • ricardopvzricardopvz Posts: 467Developers
    v2.4 released!
    Changelog:
    - Google Assistant!
    - Added support for WeTek Gamepad and other input devices
    - Updated tvheadend
    - Fix Netflix lockup when seeking and using SPDIF or a receiver without DD+ support
    - You can now open the update notification to see the changelog (auto-update will come in the future)
    - Improved Kodi AV sync
  • duepointeduepointe Posts: 35WeTek Community Member
    @ricardopvz
    i'm currently on v2.3
    has this fixed the youtube 2.01.04 playback issue? mine plays back fine but after a few seconds the video freezes and the audio just continues playing back. reverted back to the old youtube version with the old layout. Thanks.

    Again thanks for this rom! More power!
  • ricardopvzricardopvz Posts: 467Developers
    On the Play 2 I don't have any problem. The hardware and software is the same as the hub, minus the RAM, SPDIF and Tuner
  • duepointeduepointe Posts: 35WeTek Community Member

    On the Play 2 I don't have any problem. The hardware and software is the same as the hub, minus the RAM, SPDIF and Tuner

    Thanks! Just updated to v2.4 and youtube 2.01.04 is now working. :smiley:
  • vlavesvlaves Posts: 95WeTek Community Member

    v2.4 released!
    Changelog:

    - Google Assistant!
    - Added support for WeTek Gamepad and other input devices
    - Updated tvheadend
    - Fix Netflix lockup when seeking and using SPDIF or a receiver without DD+ support
    - You can now open the update notification to see the changelog (auto-update will come in the future)
    - Improved Kodi AV sync
    @ricardopvz thank you so much for maintainig the ATV ROM. Any chance you could have a look into utilizing the Xiaomi aftermarket remote wrxtasy is using too now?

    Another question: Is it possible to define in your ROM SPMC as a launcher and can SPMC then shutdown or reboot the box?
Sign In or Register to comment.
© Copyright 2014 - Creative Dreams | Powered by Vanilla
All times are UTC